logo
Bienvenido visitante. Para activar todas las funcionalidades, por favor Iniciar sesión o Registrarse.

Aviso

Icon
Error

Opciones
Ir a la última publicación
kohario  
#1 Publicado : viernes, 17 de abril de 2015 12:13:00(UTC)
kohario

Posición: Newbie

Grupos: Registered
Registrado: 17/04/2015(UTC)
Mensajes: 1

Hola.
Tengo que trabajar sobre un proyecto de android en Eclipse y estoy pasando por una serie de dificultades.
Al principio me daba dos clases de errores: unos dados por el bug del appcompat que lo he solucionado creando un proyecto nuevo para que eclipse crease el proyecto appcompat. Después he entrado en propiedades de mi proyecto, en android, abajo en librerias, y he añadido el proyecto appcompat.
Tras esto, me daba el error causado por la ausencia del director R. Lo he arreglado entrando en build path del proyecto, librerias y añadiendo los jar que están en la ruta miproyecto/android/support/v7/appcompat.
Una vez hecho esto, los errores me han desaparecido pero ha salido en el icono del proyecto una admiracion. en el panel de errores me aparecen 15.14 son casi iguales:

Archive for required library: 'android/support/v7/appcompat/R.class' in project 'OferSaludNEXT' cannot be read or is not a valid ZIP file

variando solo el R.class por por ejemplo R.java, R$anim.class, etc...
y el restante:

The project cannot be built until build path errors are resolved


Gracias por todo de antemano y ojala alguien sepa resolverlo
admin  
#2 Publicado : viernes, 17 de abril de 2015 23:04:45(UTC)
admin

Posición: Administration

Grupos: Administrators
Registrado: 07/10/2010(UTC)
Mensajes: 436
Hombre
Ubicación: España

Agradecimientos: 38 veces
Fue agradecido: 49 vez/veces in 48 publicación(es).
Yo te recomiendo quitar lo del appcompat.... :)

Si creas un proyecto desde 0, cuando te salgan los errores, quitas (borras) todo lo que te da error, que es el menu y algun recurso que crea por defecto (que no sirven para nada).

O tambien puedes crear un proyecto sin ninguna activity y luego crearla tu manualmente (haciendo click con el boton derecho sobre el proyecto y dandole añadir clase o añadir XML layout.)

Eso ya es cosa de gustos, pero usando el asistente te crea un monton de cosas inecesarias que requieren el Pu...o appcompat (app compatible) y por eso todo ese coñazo.

Editado por un usuario viernes, 17 de abril de 2015 23:05:32(UTC)  | Razón: No especificada

Un saludo,

Curso Completo GRATIS paso a paso de como programar Android
http://www.aprendeandroid.com
Usuarios navegando este tema
Salto de foro  
No puedes iniciar nuevos temas en este foro.
No puedes responder a temas en este foro.
No puedes eliminar sus temas en este foro.
No puedes editar sus temas en este foro.
No puedes crear encuestas en este foro.
No puedes votar las encuestas en este foro.